Lambda Functions with Newer Version of boto3 than Available by Default

During development of an AWS Lambda function utilizing the recently released AWS Cost Explorer API, the latest version of boto3 and botocore was discovered to be unavailable in the Lambda execution environment. The Lambda execution environment supported version of an AWS SDK can lag behind the latest release found on GitHub, which can cause supportability issues when writing Lambda code attempting to use the most recently added features of AWS SDKs. This blog post will explore using boto3 1.4.8 and botocore 1.8.0 despite (at the time of this writing) the Lambda execution environment defaulting to boto3 1.4.7 and botocore 1.7.37. This … Read More